Hyper-V: Generation 2 Virtual Machine compatibility error

Today I want to deploy a new virtual machine within Hyper-V (Windows 8.1 Client Hyper-V). The virtual machine was an Windows Server 2008 R2 machine. After hitting the “Start” button, I received an error message:

“Boot Failed. EFI SCSI Device. Failed Secure Boot Verification”.

2013-09-20_15h08_19    2013-09-20_15h10_54

The reason for this error was the new Generation 2 VM. I’ve created a new Generaion 2 (Gen2) VM for Windows Server 2008 R2, but it supports only Windows Server 2012 and Windows 8 or higher!! So just remember, when you want to create an virtual machine whit an “older” operating system, just create an Generation 1 VM (Gen1).

Comments are closed.